Ludia Forums

[Release Notes] Rise of Berk - 1.47.31


A NEW minor update is now available!


WHAT’S NEW

  • Sign in using Apple to log in to your game and save your progress online.

    • Apple Sign-In is only supported on iOS 13 and up.
      • iOS 12 and under & Android devices only have Visitor and Facebook options.
    • Read more on our FAQ page here

  • Fixed invisible Dragons when returning from the academy
  • Tapping on the Level up icon now redirects to the trained Dragon in the hangar
  • Fixed issue with Resource gathering Gobber’s Duties in the millions being rounded up - they are now rounded down instead
  • Fixed Dragon level not showing for Dragons you own in the information panel
  • Fixed crash that occurs for users when accessing Collection after getting a legendary Dragons via card packs
  • Fixed text amount on resource rewards not being displayed in Gauntlet map
  • Fixed crash when collecting card packs from in-game mail
  • Fixed infinite loading during “Connect to Facebook” prompt

Note: Please contact our support staff at Dragons@ludia.com if you still encounter some of the issues above. Make sure to include your game support key.

7 Likes

Where can we get a high res picture of the new loading screen? It’s gorgeous.

Disappointed that the game still closes when attempting to purchase a ‘Collectibles Pack’ in Odin’s Market.

1 Like

Seriously? WHAT ABOUT GOOGLE PLAY?! When are we going to be able to save progress with Google Play? Why the Apple favoritism?

Also, what’s with the new, stupid sound when collecting Duties? I preferred the old sound. Can we please, instead of changing things that aren’t broken, fix things that are? For sounds, why does the collection statue still not make any? (And why does it keep saying my storage is full when it isn’t?) Why do I still have to force the game to refresh twice before Gobber’s Duties will reset for the day?

the small update made the game unplayable for me now. Attempting to log in as guest or facebook starts the downloa then immediately the terrors got lost on the way and reverts back to login selection. I tried uninstall/reinstall which fixed similar issues in the past but did not with this update

Reported this Issue weeks ago - followed all Remove, reinstall, upgrade guidance but this hasn’t worked for weeks now. Case has been closed and no response to new case after a week… when they do fix it - I want the ability to buy the additional packs we’ve missed out on whilst the bug has been outstanding…