Ludia Forums

Revenge button not working properly

I have played 2 Alpha battles in a row, then I went to see what player attacked me on Arena mode, and if I press the Revenge button it takes me to the screen of the World Alpha, to fix this I must restart the game

2 Likes

Hey AlphaNightFury, I’m sorry to hear that is happening. Our team is aware of this issue, and they’re working on a fix.

2 Likes

Ok! Thanks a lot!

2 Likes

I have the same problem…revenge not work…and arena freezzeeee and in the arena my points by the dragons dont be right…i have 5 dragons and have 4000, 6dragons i have 3800, 7dragons and i have 3600 power… this is wrong :slight_smile: can you help?
Aaa and when i play came validation…validation… :frowning:
Sory i not speak englisch… :slight_smile:

1 Like

Hey na_R, could you post a screenshot of your defence team? Thanks!

I’ve got an example. My team with six dragons has a higher BP than with 7 dragons.

image image image

1 Like

Thank you for providing the screenshot, ZydecoMoose!

1 Like

Sorry im late.

Hello. And this is the arena, i cant play, restart, the same.restart x time.
Then one hour later i can.

Thank you.
Have a nice day.

And this bug…revenge button…Screenshot_20191010-064647

I have many bugs :frowning:

I’m sorry to hear that these bugs are affecting your game, ana_R. Our team is aware of the issue with the revenge button, and they’re looking for a solution.

In the meantime, try re-launching your game and see if that helps.

@Ned, find opponent grey button happened to me too.

Restarting the game helps but here and there it happens again.