Ludia Forums

Rise of Berk GLITCH! Buildings disappearing!

I was rotating my buildings for aesthetic reasons, as that’s recently become possible, and found out that some buildings disappear. So far it has only happened with my Viking Lodges and Viking Cabins. All other buildings I’ve tried were fine.
When I click the move option to reposition them and then click the X to take them to to wherever they were, they disappear. The space is still occupied and I can still see a few lines. I think their textures just don’t render for whatever reason. This happened with every Viking Lodge and Viking Cabin I tested it on, but restarting the game fixes it again.
Hopefully the image can show what I mean.

1 Like

FWIW, that looks suspiciously like backface culling gone wrong…

Hey ZacKow264, could you send your device information along with that screenshot to our support team here at support+forums@ludia.com so they can take a closer look? If you can include your support key in the email as well, it’d be really helpful.

Thanks!

1 Like

Yike! Not only can I reproduce this issue, afterwards the building cannot be selected.

To reproduce:

  • Select a viking cabin building that is in its original orientation and long-tap to move it¹
  • Flip it
  • Accept the change
  • Long-tap¹ it again
  • Tap or drag to move it somewhere else
  • Cancel

Most of the building will disappear and the building can no longer be selected. The “remnants” are drawn in the original rotation, which makes me almost certain this is a backface culling problem. It looks like building winds up in a state where the normals are being flipped, but the vertex positions aren’t.

This “worked” on a house, a cabin, a grooming station, a windmill, and a zippleback statue². With the latter three, however, I was able to select them, but I think this was because they have larger faces that are still visible. Probably is is necessary to tap on a visible portion of the building to select it, which is difficult in case of the house and cabin.

(¹ I used long-taps, but the ‘move’ button probably works also. However, I didn’t check.)
(² At this point, I’m going to stop fiddling with it; it appears to affect all buildings that can be flipped.)

3 Likes

Thanks so much for reaching out to us! Our team is looking into resolving this issue soon! :slight_smile:

My game has the same glitch. It’s been going on for a week. But usually it I shut the game down completely and wait an hour the houses or watertower will come back.

1 Like