Ludia Forums

Scent tower that doesn't give out scents?

#1

I just completed the scent tower but didn’t receive a capsule as part of the reward. I got a small amount of coins and a single shot of common DNA

Had anyone else had this happen to them?

#2

Hey MeatPopsicle, it’s possible that your inventory had already reached the maximum number of Scent Capsules you can have for the capsule that was awarded from the Scent Strike. If that were the case, it wouldn’t have been added into your inventory. If your inventory wasn’t full and you didn’t get the Scent Capsule, try restarting your game and see if it appears in your inventory. Our team would be happy to take a look for you if you’re still having issues after restarting as well if you reached out to them here at support+forums@ludia.com with your support key.

#3

Nope. I specifically used one of the two 5 minute commons I had before, just in case and I still only have 1 left.

#4

Just restarted. Still no capsule.

#5

I’ve had this happen before if I had any scents in the backpack. So I tend to make sure it is empty just in case the game does exactly that.

#7

Reported that same day. Not a single damned word back from “support” but that is not surprising since it doesn’t involve Ludia getting money.

#8

On the scent strike even if inventory is full it still shows the scent capsule reward, it just doesn’t add it. If it didn’t show I would say something definitely went wrong.

#10

Did you not read what I posted or look at the screenshot I posted? I had space. My inventory only had a single 5minute common and no other capsules at all.

#11

And STILL no word from “support” to the email I sent four days ago. But since it doesn’t involve me giving money to Ludia it is not surprising it will continue to languish at the bottom of the queue. They are only interested in those lining their pockets.

Having said that, as an ex IT support person I am surprised that there was not even the courtesy of an automatic response.

#12

Yeah, like that has helped!

#13

Hey AverageMeatsack, I’m sorry to hear that you have not heard back from our team yet. It might take some time for their investigation but I’ll be happy to check on this for you. Could you send me a private message of the email address you used to contact our team along with your support key? Thanks!

#14

I did read your post and saw your screenshot. It was my understanding that on the awards screen after completing the strike it flashed up other items but did not flash up a scent capsule reward and one was not added to your inventory. I also read the other post that said it may not have shown due to full inventory. I was merely stating the scent award still shows when the awards are flashed whether a person has full inventory on the scent award or not and that if it didn’t show then there was something wrong (with the program).

Sorry if there was confusion in what I had posted. I was basically agreeing that there was a problem with the game. It wasn’t intended to be anything against you or saying you did anything wrong to cause it.

#15

I finally got a response this morning. Thanks.

1 Like
#16

I’m happy to hear that our team has gotten back to you and hopefully, they’ll be able to assist you further with your issue.