Ludia Forums

Social Media Rewards

hmm, might be me, but when I do that (Facebook or Twitter) I dont see anything about a reward… It just opens the FB or twitter page…

Try it from within the game.


I did… clicked the link u pointed out. It brings me to the following page

But whatever I choose, I just go back to the game

Sorry, I have no other idea. I hope there is someone else here to help you.

After restarting the game I got 50 dinobucks !!! Thank You!!!

3 Likes

Today is Dinobuck Day on Social Media

2 Likes

I don’t understand where I can find those rewards!? Facebook, Twitter or elsewhere? Checked their Facebook and Twitter, but seeing nothing recently where they state rewards. So how to get? Also is there any feed to keep check on whenever it’s available?

  1. Open up game.

  2. Go to “News” tab in top right hand corner.

  3. click on the social media tab at top left.

  4. Click on either join/follow with facebook or twitter (press “Go”)

  5. Look at open page and then scroll down a little to read latest news and click on the link within. (Todays says Unlock Utahraptor).

  6. The page it takes you to should give a button to hit “open app”

  7. Allow the app to open. (There is usually the usual loading screen in the way which needs closing).

  8. Collect the reward showing.

The rewards are replaced by new ones every 24 hours.

2 Likes

From Jurassic World: The Game’s Facebook page

3 Likes

I have to say this isn’t really obvious advertised indeed, so thank god for the forum, otherwise I would have missed these for sure !

5 Likes

Today is Dinobuck Day on Facebook/Twitter

5 Likes

Is anyone else not able to collect rewards from social media lately? Every time I try to click it doesn’t take me to the game to collect rewards as usual.

Been working as it normally does for me, no issues that I have seen.

Thanks @Sionsith… for some reason it hasn’t been working for me since about Friday. I did a recent apple update. Maybe that has something to do with it.

I updated my phone either yesterday or Friday, I don’t remember which day, and I have not had an issue with collecting the social reward. Including today’s worked as intended.

@Sionsith I’m at a loss… I’m on an iPad and thought I did the latest update turns out I didn’t (it was my daughters iPad I updated, I like to use them as guinea pigs, lol). I have since done the latest update on my iPad and still have the issue. When I click on the link for rewards in safari browser it just takes me to the Ludia homepage. When I click the link in Chrome it makes like its going to open a new webpage but doesn’t and just goes back to the Facebook or Twitter page… :pensive:

Have you tried clicking the link again?

@Andy_wan_kenobi yes, I clicked it multiple times… want to hear something weird… I just downloaded Microsoft Edge browser just to see if it would work and it did! Why it no longer works for me in Chrome or Safari is beyond me…

1 Like

That is odd mine goes through the safari browser on my phone and works as intended.

1 Like

Just wanted to make sure the obvious fix was covered