Ludia Forums

Speed symbol glitch

#1

I have lost many battles because the yellow arrows (speed symbol beneath the health bar) has shown wrong. I have the symbol on my side but my opponent gets to go first and not with a Priority attack.

2 Likes
So Frustrated with Game Bugs
#2

I’ve seen the opposite and started with my low attack to gain speed advantage only to find out I’m already faster. I don’t understand it.

#3

Issues with this bug come up every now and again. I’m not sure if it was ever actually fixed, or if complaints about it resurface on the forum after every new update. It’d be nice to see this fixed in an upcoming patch (please and thank you, Ludia?).

Regardless, I’m fairly certain that priority of attack has always been based on creature speed, not the arrow direction. The arrows are meant to serve as an additional visual cue that “reads” the creature speed stat and points accordingly. So if it’s bugged, there’s a chance it’ll point in the wrong direction.

If you don’t trust that the arrow is right, you can always tap on both creatures in battle to view their speed stats. If two creatures share the same speed stat, then the higher level creature will go first.

If this isn’t the case (if T-rex is attacking first instead of Allosaurus, if Pyrritator is attacking before Procerathomimus), then please correct me…and you should really send Ludia’s support team a ticket to remind them that this is a serious issue. :slight_smile:

#4

Yep. Also especially after using priority attack.

#5

It’s one of the multiple well known glitches Ludia couldn’t be bothered stomping on as part of the update, probably because there is no profit in it

#6

This works most of the time but begins to get hard to follow when you and you opponent are both using Slow Down and Speed Up attacks.

What I don’t get is after both players enter their attacks, the game seems to know who is supposed to go first so it seems like it shouldn’t be that difficult to figure out who to put the first move indicator on.

#7

I agree… Most of the time I’m able to follow the slowdowns and guess who’s going to attack next, but the arrow can be kinda misleading. Maybe now that the damage calculation bug has been dealt with as of this update, the speed indicator will be next. 🤷 Hard to say, though.

#8

This speed symbol issue is the same as other display issues. After you’ve been playing for a while, you start getting display issues where, it’s the speed arrow that tends to be the first affected, but then the attack buttons don’t show or other things don’t show until you enter a match and nothing shows although you’re actually in battle. Finally for me on my Ipad, the game literally crashes to my Ipad home screen when I enter a match.

I’ve had it where both my phone and Ipad game freezes up upon where the “You Win” or lost screen comes after a battle. It is just stuck there and you have to kill and reload the game.

#9

To be safe, I usually calculate the speeds with slows and speedups and levels/rarities etc. Often with 2 of the same dino, with one a higher level, it will show the lower level one is faster, when in reality, the higher level is

#10

That sounds like a memory leak which is quite possible. Memory leaks happen when routines aren’t closed out or released properly resulting in the program thinking the memory is still in use even though it is not.

#11

I agree this one is aggravating. I really do wish they would also let you know who has the ‘advantage’ when you have the same creature/level. It makes a huge difference, and right now it’s a coin flip (and one that I feel like I lose almost every time). I’m not even sure how they determine who goes first, but it isn’t random, because if you are in a battle, it never changes. The speed arrow is really important as you gain levels. I’m in the aviary, and with all the debuffs and positive buffs it’s impossible to keep track of.

#12

How long has the speed indicator been broken now? I really don’t have the time to do the math with different slowing and superiority strikes. Can we fix this or dump it? Lost three battles due to it tonight. Supposedly my move, but nooooo…

Have started noticing that stun doesn’t often work correctly either. I can stun them, but then they still get the next turn. If they are faster they recover and get the next turn, that doesn’t work when I am faster though, they always get the next turn.

#13

I can answer to the stun. There are two different stuns. One is a half turn stun and the other a full turn stun where you have the end turn button. If your fast like the Utasinoraptor and you do the instant charge stun (half turn) it will stun your opponent that round. Take the greater stunning impact of the Stegoceratops, that will stun for a whole round even if your opponent is much faster.

#14

Thanks for the explanation - that is super confusing. So, how do I figure out if stuns will be half or whole? It is not indicated anywhere that I see. In fact both Stegoceratops and Utasinoraptor say that they stun for one turn. Does it need to be a Greater Stun to be a full turn? Thanks again!

#15

The explanation above was confusing.
There are no half or whole stuns, there are just stuns. What matters is the speed of both dinos.
Example 1:
Turn 1: Utasino: Critical Impact
Stegocera: Stunning impact
Turn 2: Utasino: End turn button (because in the turn before got to attacked stegocera)
Stegocera: Strike
Turn 3: Utasino, whatever

Example 2:
Turn 1: Stegocera: Strike
Apatosaurus (which is slower): Pinning Strike
Turn 2: Stegocera: Stunning impact
Apato: Is stunned, and since is slower, it doesn’t get the End button turn.
Turn 3: Stegocera: whatever

As you can see, it depends on who is faster. But in both cases, the dinos who got stuned didnt get the chance to attack the opponent.


Here’s a complete article on the matter, hope it helps

#16

Thanks, that was how I assumed it worked actually, but that proves my point that stuns are not working properly. I will have to take notes when it happens again. I have stunned a slower opponent Allosinosaurus with my Utasinoraptor, The stun symbol showed and then he immediately came back into the fight. When reversed I had to use the End Turn button. This happened twice last night. The first time I thought I missed something, the second time I realized there is something wrong.

I will read the article though (thanks) perhaps I am not understanding it still.

#17

That happened because utasino is faster than allosino

#18

Read the breakdown and was starting to figure that out. That’s really strange how as a faster Dino the slower one does not lose a move. I hit and stunned it. Should it not lose the next turn? Why does it come back and hit me that same turn? Seems like a stun should give me the next hit.

#19

You do lose a turn. Doesn’t matter if you’re faster or slower, if you get stunned, you lose a turn.
About the situation with Utasino and Allosino, im gonna assume that this happened:
Turn 1: Utah: Distracting impact
Allo: DSI
Turn 2: Utah: Instant Charge
Allo: Is stuned, and since is slower it doesnt get the “End button turn”
Turn 3: Allo: Instant Charge
Utah: is stuned and gets the “End button turn” because he is faster.
Turn 4: Utah: whatever

Can you see how in turn 2 allo lose a move? And in turn 3, allo uses a priority move and stuns Utah, also making him lose a turn.

#20

Thanks again Wilshire. I see what you’re saying and it makes sense. I am going to play close attention to see if I can document it. I appreciate you following up with me on this, as it totally surprised and killed me last night in PvP.