Ludia Forums

Speed up in breedary took runes


I was doing breeding task today, Whispering Death×Wraith, and hit speed up to get it over with. I hit speed up,pressed confirmation,then it took my 25runes,I watched them disappear. Then instead of giving me my dragon it went back to breeder like the screenshot I posted. I didnt try again because I dont want to risk losing more

I’ve had this happen to me a few times. I don’t know why, it just seems the breedery can be a finicky mistress sometimes.

What is usually the case is that even though it freezes, or shows that the dragons are still breeding and nothing changed, even though your runes are gone, is that the resulting dragon was still placed within your roster. If you exit out of the breedery and check, then go back to the breedery, it usually resets itself back to normal and all should be well.

I’ve even tried clicking on the ‘Speed Up’ option numerous times, and it never took multiple amounts of runes. It just didn’t respond at all.

If that is not the case, however, and you are left without resulting dragon and your runes, then I would head on over to the in-game support to let them know what happened. They should be able to look at your account (be sure to provide your support key, the usual) and give you your missing runes, at the very least.

2 Likes

Well it didnt freeze on me,the timer was still ticking. And honestly I didnt check my roster to see if I had gained a dragon at that point and just went about doing some other tasks in the game. When I did return to the game couple hours later my breeder was empty. So it must have given me my dragon,I just needed to restart game. Which I should have done before I posted this…my bad

1 Like

I can’t say for certain if the timer itself actually froze, or if it did every single time, so I suppose I was using the term a bit loosely :sweat_smile: It was more in the sense that nothing was happening after using runes to speed it up. I should have been more specific.

No worries, though! That sort of thing is a bit jarring, and there’s nothing wrong with seeing if anyone else has had this sort of thing happen. That’s part of what these forums are for; helping each other out!

1 Like

Hey AlphaAva, our team would be happy to take a closer look at this for you to see if any problems did occur during your speed up.

Could you reach out to our support team here at support+forums@ludia.com with your support key, along with the date and time of when you did the speed-up? Thanks!

1 Like