Strike event glitch and now I am mad

So I just attempted the 3 step strike tower and on my final battle whilst using my trago, the game just stopped and I sat there for 4 minutes. Trunk happened but then the battle proceeded as usual so I thought I was safe. Naturally trago slaughtered the raptors but then once the last one was one hit after as, I got the defeat screen. Bear in mind that I still had a full health stegod, indoraptor and alanky. I have heard of this glitch happen before and I am not happy. So I would like to receive the incubator owed to me or the 200 hard cash to redo it.

2 Likes

I’m tired of problems with shields. Each time the game stops and I lose while I have to win. Moreover, it’s annoying to have to start again, and risk losing when I change my strategy. Is it possible to have compensation for this problem ???

Same problem, Attack dont launch

Just made a topic for the same exact issue. I m mad too
:rage::rage:

Known problem. Been on the forums. Simple solution until fixed was not to use it. At this point it is the end user’s own fault.

Same, alanqa with shield and after a long wait i see the defeat message… sad very sad

Defeat, I try to paid and nothing.
I restart my game a have a New chance and i win.
Damn i was sad on my first Battle my Irex dodge swap Attack and OS velo.

Yep. Going for the epic incubator strike event, twice it just sat there while the timer ran down and then decided it had beaten me anyway. What a load of crap.

Same here. It’s just sad… It’s my second time I had this crap.

46415896_2195649680445833_9174815189600567296_n123

Restart the game and you will have 0 loses and you can try again :slight_smile:

1 Like

didn’t work for me man :frowning:

I met the same issue. I fixed it by doing another strike event tower first, then when I came back, the lose on epic was gone.

yeah that worked for me as well thanks man!

Happened to me as well, luckily the retry was free. Sadly I tried the same tactic but without the invincibilty, but bother of their creature got a crit (5%:-)))))))) and bcuz of this I lost and had to lose 200 bucks. :-)))

Hello,
I was in the middle of the fight for the epic strike tower and out of nowhere a defeat sign appeared and now I have to pay 200 while I was winning.
Is there a way for me to do it again without paying?

1 Like

I had the exact same happen man, did the epic strike and got a defeat sign in the middle of an animation even though my dino could not have died(even with a crit). Like this bug basicly robbed me of the epic incubator :S

1 Like

Same thing. I reloaded and was able to do it again but got the same bug


Same here! Can Ludia give me my incubator back? The easiest epick strike tower… And it even wasn’t my first time. I’ve got the same with Mono epick strike tower… :(((

Can someone from Ludia help us? I have prove :smiley:

I got a loss because of it man, tried to reload and did the same thing… weird how it worked for you but not for me :frowning: I am happy for you tho dont get me wrong glad you got it!

OK so clearly it s a known problem and not an isolated case. I hope Ludia will recognize the problem and give us a compensation.

1 Like