Ludia Forums

Stuns and destroy shields attacks not working Arena

This is for reporting bugs only, if you are having trouble making a purchase or need help recovering your account please post in Help & Support here.

Please fill in the following fields!

Bug Description: Stuns and destroy shields not working in Arena battles, case of today 1 in 7 stunning attacks not working and 2 destroy shields attacks did nothing. On average over 40 stunning attacks less than 25 percent working , not 75 percent ( note Dino’s attacked had no immunity) ! Today destroy shields , would not destroy shields.
Similar yesterday, 4 stunning attacks in row, only 1 worked.

Area is was found in: Arena

How do you reproduce the bug:
Step 1- play any Arena match
Step 2 -
(add more if needed)

How often does it happen: every match

What type of device are you using: Android

Anything else? (add screenshots or additional information here)

I noticed that too, stuns works alot less in the tournament. Purrutaurus in particular cannot be stunned

Not sure why Stuns not working. Today it was significantly one player, stunned their Dino’s 6 -7 times in a Row and nothing worked! For same player shields destroying attacks didn’t work either.
Not sure if Arena issue or what. Have noticed Stun issue a month or so ago, been keeping count recently 10-11 out of 40 worked.

Hey Derek_Storey, could you let our team here at support+forums@ludia.com know which shield destroying ability is not working correctly? If you have any other information about your battle as well, it’d be really helpful.

Thanks!

It was Gorgosuchus Defence shattering attack against a AlanQa (epic flying) 100 percent shield, noticed stuns didn’t work either with the AlanQa but maybe that was a coincidence.
Regards Derek