Subscription VIP rewards are not functioning properly

Hello,

I recently completed my 7-day VIP trial and allowed Ludia to continue to process my 9.99 subscription. Despite having the timer on the incubator run out, I am unable to click it (nothing happens but it still says “free”). I have tried contacting the in-game support client for assistance but have received no response.

I am currently receiving the 30% range/power boost but am not able to claim the VIP incubator.

Thanks,

Profirix

UPDATE: It finally allowed me to claim it. Based on the response I got from an employee, there was some kind of error that considered my trial to be an 8 day trial and did not end until 4/7 at 11:30PM local time. I still paid in advance for the month but it did not officially offer the reward until just then.

Did you get one when you signed up to the free trial. You only get one not every time the subscription resets.

You are not allowed to receive the incubator until your trial ends. I assume this is to prevent gaming the system.

Fair play. I wasn’t sure how it worked with the free trial.