Ludia Forums

Thawfest Games keep crashing

This game is entirely not playable. Every 6 out 10, always crash right when starting the battle. Not only I lost 1 point, I keep loosing battle points without even playing it. Is this ever going to be fixed?

That’s not good. What kind of crashes are they? Complete game crashes, where the game closes completely? Or are you getting discrepancy/server errors?

I’m asking because depending on your answer (and what you’re playing on, iPhone, Android, etc) there’s some things you’ll be able to do too that should help fix, if not make for a smoother playing experience. I’ll be happy to go into further detail when you respond :slight_smile:

1 Like

Screen turn black and app closed. The game closes on several points:
(1) after a few battles or upgrading levels
(2) after a few back and forth between main screen collecting rewards and battles
(3) during upgrades
(4) network reconnect message appeared
and more…

Basically I have to get used to restarting after a few battles (~4-5 battles or 3 upgrades), otherwise I will experience app crashing and loose either points on thawfest games, or dragons on upgrades, or energy and fishes and treasure coins.

I have better chance of not crashing if I stay inside the quests windows. I can have more than 4 battles, sometimes if lucky, up to 8 or 9, but all depends if I need to open the viking chests.

I have continually tested these since I posted here last, the situation never changed.

The latest problem was the lost of trophies out of the blue. I just found out that it was caused by mixed of battle state (thawfest or quests). I already moved to quests from thawfest, but the game state remains in thawfest. So I have to pay close attention to the energy count. If it shows up RED with lesser energy count while I am in the quests, then the mix is happening. At this point, I have to restart.

Hi @elseane, I had similar issues on my old device - may I ask if your device has the recommended (necessary) amount of 1.5 GB RAM?

Connection issues occur on my (new) device as well, but nothing else.

1 Like

Unfortunately, as @Bee stated, all these problems happening all together and with the frequency of occurrence, it usually indicates an issue with the device itself. Either with it not meeting the requirements (and you can usually get away with skirting beneath the minimum requirements, but you’ll probably still have some issues here and there) or with your system not having enough internal storage space available and/or RAM.

You can get by with restarts because you’re flushing the cache when you do. So things like clearing the cache (if you have an Android) after closing the game will probably help make things a bit smoother, but I can’t really say by how much. And when things get really hairy, probably full reinstalls. But that’s all flimsy bandaging and duct tape at best. Your best bet would be to free up internal storage, or, if that’s not the problem at hand, play the game on a device better suited for the game.

I know that’s easier said than done, considering we work with what we got :confused: I’m sorry. I can say, however, that the connection issues are (again, as @Bee said) a problem with the game itself, and not on your end. For whatever comfort that may provide.

1 Like

I am using mini ipad. I have excess of 10GB+ in it. How do you factor that into 1.5GB RAM?

Also, how does that explain the thawfest energy level get mixed into the quests?

I have constantly lost thawfest trophies twice (2x) after a restart and a dragon upgrade. All I did was click start battle and crashed. The next time I logged in, it took my existing trophies. How is that considered RAM issue, and not a bug?

1 Like

RAM is not the same as storage. RAM is an acronym for Random Access Memory and, in the most basic sense without going into needless detail, it essentially plays the part of: more RAM = ability to do more, play more intensive games, use more intensive programs without lag and/or strain on your system, etc, etc.

To your other questions, I’m sorry for not touching on this in my earlier response, but the Thawfest energies getting mixed up in main quests is considered a bug. So you’re not wrong there.

However, unless I’m misunderstanding something here, if your ipad is just plain crashing after trying to start a battle, that really heavily implies an issue with the system and requirements not being met. Usually RAM related and/or the graphics card (which, from what I’m aware, is just put all together in a SoC for smartphones((and tablets, laptops, etc)), and since you didn’t specify which mini ipad, I went with the specs of the one released in 2012, which uses an Apple A5 SoC). Ludia’s page on requirements is kind of…bareboned, so I can’t say if there’s a possible clash there.

All that aside, I was reading more about the specs on the mini ipad, and it says the original release only had 512 MB of RAM. Which is looooow. It works for basic things (which I’m assuming was the purpose of the product? I vaguely remember some ads, I think), but if that’s the one you have, I’m not surprised it’s giving you trouble. The ipad mini 2 only has 1 GB of RAM. If you have the ipad mini 4, that one has 2 GB, and 5 has 3 GB.

And all that aside, are you saying too that you’ve lost Thawfest trophies just from upgrading a dragon? Because that is definitely not one I’ve heard before. You would definitely want to write into support about that, unless I’m misunderstanding. If you’ve lost dragons due to crashing while upgrading, you can still write to support, but I can’t promise they wont give you a one time only refund, especially if the problem stems from your device.

To contact support via email, you can reach them at support+forums@ludia.com. Good luck! :+1:

2 Likes

I did not know what my iPad mini RAM was, hence I simply put in the storage size just in case if you use it to compensate. However, with your last info, mine should have only 1GB RAM.

As for the trophies lost, it happens on several conditions as follow:
(1) After dragon upgrade, go to thawfest and click to start battle, app crashes, when returned, the trophies get deducted as if it was treated as game played and lost.
(2) The energy mix-match, which you agreed it’s a bug.
(3) Can’t play more than 3 games in a row, app crashed (memory issue or network issue, unsure)

I have reported some of these problems to support+forums@ludia.com, but they told me to post the problems here.

Just got the RAM info that my unit only has 1GB.vI am not quite certain that RAM issue is the only cause of app crashing.

I also notice that switching between thawfest & clan & quests & chests can easily crash the apps as it attempts to grab data from network. This type of switch does not trigger “network reconnect” dialog, however it seems to bail on failure to get data in time.

Oh! No, unfortunately, the only way you can get more RAM is by A: the device being a PC so that you can purchase physical RAM, open up the tower and replace and/or put it in yourself, or B: purchase a device with more RAM. It’s one of the drawbacks of having mobile systems, since RAM is relatively cheap and instead of shelling out half a grand to a couple grand for an entirely new system, you can just upgrade it (and other pieces) yourself to keep up to date with games or just…your system running smoothly, really. Depending on how long you’ve had it.

As to the problems with the game itself…I’m not entirely sure why support sent you here? Did they not…help you? I don’t really understand that. I mean, I’ll do what I can to help you, I just…I’m not really getting the logic there.

Anyway, from the sound of it, the dragon upgrade might be too much on your system since it falls beneath the minimum requirement of 1.5 RAM. Maybe in that your system was already struggling with loading everything and dealing with the workload of animations and textures and models, etc? And then when (if?) it was lagging during this time while you tried to go to Thawfest to start a battle, it was just too much, hit the limit, and the app had to shut down.

Then, for the next one, I reread your earlier post. Is the ‘forced into Thawfest battle’ problem still happening? I think I do remember others mentioning that a while ago, but I thought that was fixed. I think I misunderstood your problem and thought you were talking about another bug, which is where there’s a graphical error of the Thawfest energy remaining in the HUB and Quest page that goes away if you go into the Dragon Select screen for a Quest battle.

For the third, that would also fall under a problem most likely stemming from not meeting the minimum requirements. If it were a network issue, you would be inundated with network failure dialog boxes, or whatever it was they say. I can’t remember the exact words…Network failed to connect, or something? And that could be a couple of things. Problem with your modem, problem with your router, problem with whomever you use for service, etc. You could try a quick and easy ‘Forget this network’, and then log in again, if that were the case. Usually when it comes to those problems it’s a pretty easy fix of turning things off and then on again (with a 15-30 sec pause between).

But that’s assuming any of those are at fault. Which they could be, but I kind of doubt it, honestly. Still, those options are there. I will say I am curious why you’re getting anything about network stuff. Maybe it’s a mixed bag.

1 Like

I had 1GB RAM before as well and game kept crashing, especially if I switched a lot between different environments (quests, exploration, Alpha, feeding dragons was very likely to crash in general, …). I’m very sure that the programming style of this game is not properly cleaning RAM that it doesn‘t need anymore and as it‘s a game loaded heavy with graphics, this is causing devices with not enough RAM to end the RAM-consuming task (shut down the game since no RAM left).

Since I switched to a device with 3GB RAM I didn‘t have a single crash or any energy getting mixed up except for the beginning of Arena where it was very bugged. I’m very sure that something like mixing up energy is more likely to happen if your device has not enough RAM (=is not fast enough) as well. I get lots of reconnects though, that‘s definitely a bug.

3 Likes

Bee, those you wrote were exactly what I have in mind. Since I do not have a higher end device to spare playing game and validate them, I can only hope to report this flawed programming style, and they are willing find a way to make improvements.

The same unit is playing other high intensive graphic games. These games perform smoothly, with some hick-ups but never lost points or messed up points or rewards. Crashing is one thing, but taking points before a valid game end status is achieved, that is a bug.

The initial released versions never had this problem. This happened after later subsequent upgrades in the past few months. It started to crash only after I was forced to log into facebook after that major upgrade, lost my entire account, support team helped retrieve my game data, and used game center instead. After that, all these glitches started to appear and recur, more and more with each upgrade.

Frankly considering my low end unit, I can settle with crashes, but losing points due to a click to start battle and crashed, mixing battles and thawfest scores, those are the mix of game logic issues.

Didn’t you write you still encounter network reconnect issue? If so, then the Mysterious Ambassador assumption of network issue is invalid. Unless, you and I and many others on this forum reported this, we all have router or network issues?

1 Like

A few things you mentioned here:

(1) RAM issue and OS issue. Nothing I can do with RAM, since this is an iPad unit, and I have no spare unit for gaming. OS, definitely upgrade them as it comes along, no miss there.

(2) Support helped me retrieve my game back, that’s all they do. As for any bugs or problems they deem as non-supportable immediately, they told me to post it here. I am not sure if the developers actually get their bug reports here? That part I don’t get either.

(3) Limited RAM causing it to shutdown, I get now when @Bee first mentioned 1.5G minimum. However game data should not be load intensive. Is this app more graphics intensive than city building games or RPG? That the graphics load screwed the data, and unable to log and identify a crash when it happens?

(4) The “forced into Thawfest battle” problem only just happened since last app upgrade. It is not graphical error. That I know for sure. The steps are, play thawfest game, when completed, switch to quests (energy screen mix match), play a quest. I lost the quest, and continue playing another quest or switch to collect chests. Shutdown game, and restart, then enter thawfest, trophies were deducted.

(5) The “network reconnect” issue. I tried everything from forget network, reset network to reset entire device. Nothing helps.

BTW, FYI, this device plays another high intensive graphics. Titan is only 600MB, but this game is 5GB. That game crashes once if played longer than an hour but does not lose points or mixed calculation. Like @Bee said, “the programming style does not efficiently clean the RAM.” That is a bug, isn’t it?

What helped a lot to avoid crashing for a certain of time of playing (a few quests or one feeding) on my old device was doing a clean reinstall (completely deleting app and install again). Your data is saved by your Gamecenter account, so that should not be an issue, and after I did that I needed to restart (on purpose) much less. Somehow the iOS version tends to mess stuff up if you only download the update without deleting the game first (I do that on my new device as well). Also helpful: Google how to clean your cache manually on your device. Should be something like first long-press lock-button (until option to shut down appears) and then long-press home-button for Apple devices.

Yes, you are right, there are connection issues. And I can tell that this has nothing to do with our devices since one time I got too curious - connection issues appeared ingame (pressing reconnect-button would lead to a loading screen and then error message again), I left the game (without closing it), opened Google in my browser which was fully loading, switched back to the game and had to hit the reconnect button a few more times until the game finally managed to get connection to Ludia servers.

2 Likes

All those you recommended with reinstall and clean cache, I tried. I even reset the device entirely. Since it is a designated game unit, I tend to keep it as easily resettable as possible. Nothing really helps. With each upgrade, it keeps releasing new issues. When a game logic is the issue, and RAM cleaning is another, it’s tough to work around it.

As for that network issue you had, I concur. I even have my WiFi connection lost (device WiFi icon is gone, but router and network are active tested concurrently on other units) in the middle of the game when I hit reconnect too much time. The only way to fix this, for me, is to shutdown the game, and restart.

1 Like

-Fair warning, I’m running on no sleep so if my reply is a little weird sounding, I’m so sorry. I’m trying very hard to be coherent-

I do want to mention too that the only reason I mentioned the thing about fixing network problems is only if you just got a slew of those ‘Network Failed To Connect’ errors. As in one right after the other. I should have clarified, since there have been reports (and this has happened to me as well) that the game will randomly drop out. That’s a server side issue, and not a problem with our devices. But, again, the difference is really if you’re getting constant drops, in which case you would want to cast a wary eye towards your own setup, versus those that happen every now and again. (Also it makes a difference if these drops only happen using mobile data or not)

That’s on me though. I should have been clearer. I assumed, from what you were saying, you were getting nonstop drops instead of the every now and agains.

  1. RAM is a biggie, so this is going to be a problem you’re going to be stuck with, unfortunately. At least until you get a new device. With every new update (and they’re not exactly clean updates, as we’re all aware >_>) the game is getting bigger and more graphic intensive. More to load, more strain, etc. It certainly helps that you’re keeping up to date with the newest OS updates (though sometimes those can cause issues too buuuut that’s a whole different beast), but in the end, RAM, system storage and the SoC/processors/graphics cards are your biggest things when it comes to gaming. In your case, it’s all in the RAM.

  2. I…I’m not really sure what to say to this? Developers don’t…that’s not how things are supposed to be run. There’s a system to these things, and support is supposed to be there to neatly file things for developers to go through for efficiency in hotfixes and updates, etc when tickets are sent in. Granted there’s a little more to it than that (we shouldn’t be the first net, for example, there should be a QA team, and that’s not even touching on the fact that this shouldn’t be on the shoulders of just one group) and while different companies have different practices, that is, essentially, its core.

I mean, it isn’t as if forums aren’t used as, uh, a forum, to learn about bugs, but solely? Or at least mainly? I’m surprised they didn’t even give you a basic reply of ‘Meeting requirements’.

  1. The thing about these games is that you never know how they were built. What they were built with. There’s tons of different things that could be making this one more labor intensive than the next. Messy code (coughthisgamedefinitelyhasmessycodecough), shaders, the dpi of their textures maps, how many clips of animation with how many frames to them, the size of the models and their animations, etc, etc. RPG games tend to use looped backgrounds which can be achieved with a handful of painted tiles that are then puzzle pieced together in a way that looks fresh and new.

Don’t get me wrong here- that’s literally every game ever, haha~ I’m just saying that in terms of thinking they have big expansive worlds and backgrounds, they just use the same tactics as everyone else. And their models tend to either be teeny weeny, pixelated, and/or have very limited frames/frame rates. And that’s only for fights or environments. Dialog and HUBs usually get 2D characters (which we do too, natch’.)

I might very well be wrong, but the models used for the battles look to be the same models for petting/feeding. They might be the same models, but put in separately in a ‘scaled down’ version. Like, 20-30% or something.

All of that is being pedantic and needless over speculation, though. It could be any number of things that makes this game more demanding than others. It could be all of the above. Some games are just that way. In the end it doesn’t really matter because those games are not this game. Other than messy code making the game more demanding on systems, that’s not really enough to warrant sole blame for the troubles you’re having.

Mainly because others, like @Bee, have had these troubles and got through them by upgrading to systems that met or surpassed the minimum requirement. Also because these are all (save for the others that have been pointed out) classic signs of a system that cannot handle what it is being tasked to do.

It’s unfortunate, especially since you’re just skirting beneath the line. Sometimes you can get away with that. And I know it’s frustrating because, as I said before, we work with what we got. In the end, you’re still working with a device that doesn’t meet the requirements listed to play the game smoothly. So when the game doesn’t play smoothly, you really shouldn’t be surprised. I’m sorry you have to deal with these frustrations, though.

@Bee had some really good advice too. I hope at some point, any of it is able to be of help to you.

1 Like

I am a bit puzzled by your last reply. Let me try to understand it:

(1) You believe that the @Bee mention of weird programming style in handling unused RAM is not a bug, and hence it is ok for a game app to keep increasing RAM usage without reclaiming? By that means, it’s either I use a better device or expect to quit playing after a few more upgrades?

(2) The support email is responsible for submitting bug or problem reports.
I will try to submit these exchanges as bug or design flaw. I hope they will acknowledge it per the support structure you mentioned, or get an answer that they do not consider it as issue.

(3) The graphic intensive game I am playing is 5GB+, that alone tells how intensive the graphics are. Based on the visual effect, I highly doubt it’s looped backgrounds. They just use local offline storage to compensate, and making data sync quality a higher priority so they can reliably get paid without the fuss of angry users.

(4) As for @Bee’s advice, as I have already replied. Not working for me. Since the point lost really tied with the game logic, more than the RAM issue. I really don’t mind the crashing, well aware of my low end unit, but losing points or dragons just because the game fails to recognize an authentic action vs a crash is entirely different thing.

Well, actually, yes? Yes and no.

That’s how technology works. When better games come out, they have higher requirements. Expecting to be able to use older and more outdated technology is folly. If your system is already having trouble handling the game as it stands now, what makes you think it will be able to handle it in the future when it has more features and is larger in size?

I’m sorry if I’m being convoluted, I know I can let words get away from me. To be clear: your device simply does not meet the minimum requirements. Therefore, the fact that it crashes as often as it does and does not play smoothly, is not surprising.

There are glitches, and bugs, and messy code, but these things don’t account for the troubles you specifically are getting due to your device not meeting these minimum requirements.

The programming style @Bee is referring to is messy coding. The suggestions for reinstalling and clearing your cache are the same I gave to them when they had the same troubles. I’ve repeated them to you, they’re repeating them here as well. It usually works for people, and I’m sorry it’s not working for you.

If you’re contacting support to tell them about these specific issues, then I think I can understand why they sent you to the forums. They’re just there for things they can actually do something about. Quick fixes and answers. Are you writing them telling them your specs and that you’re getting these crashing problems?

They’re not there for design flaws either. Criticism about that sort of thing does belong here. And when I said ‘sort and file’ it wasn’t intended as if they’re secretaries. I’m sorry if that was confusing? That was in regards to actual bugs. Things that can be fixed in a hotfix or an update. Messy code would need a complete overhaul.

This 5 GB game you keep mentioning is really apples to oranges. It doesn’t matter. That game is not this game. It can do things a million different ways different than this one. And as you brought up RPG games, I used RPG mobile games as an example as I thought that was what we were talking about. In the end, none of that has any bearing on this conversation. Just because you can play one game, does not automatically mean you can play another. (Also, as an aside, while they may or may not fall within the very specific term of ‘looped’, I can pretty much assure you they heavily reuse assets and do the same tile/pattern technique everyone else does. It’s not a slight, that’s just how things are done. Work smarter, not harder and all that.)

I understand you’re frustrated. But you can only keep trying to fit a square peg into a round hole for so long. If you don’t mind the crashing, and you’re well aware of your low end unit, you’re going to have to swallow the fact that there’s a very real chance you’re going to lose things in your play sessions. It does sound like a very frustrating way to play, though. I’m sorry to hear that the usual things that at least alleviate these issues somewhat are not of any help to you.

1 Like

I understand what you meant, but I have to disagree. Until I find a way to debug the flaw in this game logic and its “programming style”, I guess I’ll just have to consider this game as one that can only cover lesser users limited by only new devices, and be ready to get booted anytime on upgrades.

Alright I was hoping there was some actual communication misunderstanding here but there’s not. You can’t ‘debug’ the game without violating the ToS. This isn’t a game where you can mess with the apk or ‘mod’ it without the act actually being illegal.

This is not a single player game. This is one that is online, and the code is protected by copyright, copyright is protected by lawyers. You can and most likely will be banned as messing with the codes of games like these are considered serious offenses.

I don’t quite understand the need to bolster yourself with the ‘lesser users’ thing, but it is vexing that you are so determined to neither grasp, nor accept, a very simple fact. It’s not your game. But it is still a game. If you are unable to enjoy playing it using your current device, you’ll have to either play it on a different device, or accept that your own simply will not be able to play it to it’s best capacity in the game’s current state if reinstalls, cache flushes, system restarts, and ensuring plenty of room in system storage does nothing at all to aid it.

Good luck in the future.

1 Like