Timeout contacting the server


#1

I get an error stating timeout contacting the server. No matter how many times I try. I have reset modems, routers, cleared wifi settings and no help. RIse of Berk has the same error happening. I can connect on my many other games and have a stable internet connection. Just the 2 Ludia games don’t work. Seems to have happened when I went to Xfininty Xfi modem.


#2

Hey OB1, do you get the same issue if you try connecting to another internet connection? It’s possible that there could be an issue with your network. However, if you’re still having the same connection issue after connecting to a different network, contact our support team here at support+forums@ludia.com with your support key and a screenshot of the error so they can take a look.


#3

So as it turns out, my Xfinity Xfi modem XB6-T was at the highest security setting. Everything worked perfectly except I could not get into either Ludia game Jurassic World or RIse of Berk. After adjusting the level to a lower security setting both games now load with no other issues.