Ludia Forums

Titan uprising

#1

Where have my repeatable quests gone?

#2

…and how do I get eggs now?

#3

Hey Slimming65, you can find the repeatable quests by tapping the Play button and going into the Exploration map, from there you should see a compass icon, the repeatable quests are located in there. We have also moved the other quests into the compass that is found on the home screen next to the Play button. I hope this helps!

1 Like
#4

We want to choose our level of repeatable quest. Due to needing to auto play or maybe a dragon you need is breeding etc

#5

Ok thanks for your help

#6

My game is glitched, it won’t let me battle in any mode and it permanently displays 1200 power and won’t let me select my team. I tried redownloading but it’s still glitched. Anything I can do?

#7

Hey OverlordDeath11, could you reach out to our support team here at support+forums@ludia.com with your support key so our team can take a closer look at your account to see what the issue is? Thanks!

#8

Contact support

#9

Just contacted them. Hope it’s fixed. I’m level 13 and have got a 3 star team on Burning Barrens

#10

Ludia still hasn’t fixed the problem, any tips on how to contact them directly instead of just emailing?

#11

Inside the game. You can message with them

#12

How do you contact them?

#13

Enter into your profile, then into the settings tab, then go down and click on Help & Support. In the upper right corner you click on the message bubble.

#14

How long does it usually take for Ludia to fix the problem?

#15

So, um… my game broke like a week ago and Ludia said they would fix it, but now when I log into titan uprising it says that I don’t have a good network, but I do. I don’t know whether or not it’s because I’m on a school IPad or what, but any tips on how to fix it?

#16

Hey OverlordDeath11, if you’re having connection issues, sometimes force closing and relaunching the game could help. There are also some additional troubleshooting steps on our FAQ here that you can try as well: https://ludia.helpshift.com/a/dragons-titan-uprising/?s=troubleshooting&f=why-did-my-game-close-unexpectedly&l=en

However, if you’re on an older device, it might not meet the requirements needed to run the game. Our FAQ here has more information on device compatibility: https://ludia.helpshift.com/a/dragons-titan-uprising/?s=hot-topics&f=device-compatibility&p=all.

#17

My email won’t work so I’m just gonna say it here, I need help with Rise of Berk, my game won’t open because it says that I have a bad connection, but I have a good connection, I’m on IOS 12 and I am on an IPad that I get from my school district, same with Titan Uprising as well.

#18

If possible, could you try reconnecting to a different internet connection and see if that works? Our team would be happy to take a closer look to try and assist you as well if you reached out to them here at support+forums@ludia.com with your support key.

#19

Nope, tried that, doesn’t work, and email doesn’t work. I’ll try sending again.

#20

I think it’s because my IPad blocked the game.