Ludia Forums

Too much time after collecting DNA

#1

This is for reporting bugs only, if you are having trouble making a purchase or need help recovering your account please post in Help & Support here.

Please fill in the following fields!

Bug Description: Screen returning to normal game play after collecting DNA taking far too long and showing redundant information. Highly aggravating.

Area is was found in: all areas and especially while driving.

How do you reproduce the bug:
Step 1- This timming issue occurs after EVERY collection of DNA.
Step 2 -
(add more if needed)

How often does it happen:
After collecting DNA and especially long when driving somewhere.

I have a HUGE problem with amount of time it takes after collecting DNA for the game to resume normal game play. The screen shows redundant information (how much DNA was collected) twice and the drone with spinning blades twice. This slows down the game a lot! I have timed it and it can take 20 to 40 seconds to resume gameplay… This is FAR too long… Especially while driving and trying to collect DNA and drops… This feature makes the game hard to deal with at times. I highly suggest revising that.

What type of device are you using: Samsung ThinQ

Anything else? (add screenshots or additional information here)

#2

Hey JJZ1980, the loading time of the game usually depends on the strength of your internet connection. Could you try some of the troubleshooting steps on our FAQ here and let me know if it helps:https://ludia.helpshift.com/a/jurassic-world-alive/?s=troubleshooting&f=why-did-my-app-close-unexpectedly&l=en
If you’re still having issues after trying those steps, please feel free to contact our support team here at support+forums@ludia.com with your support key, and our team can try to investigate further.

#3

Unfortunately its not a connection thing. This became an issue after 1.6 and has been widely reported already.

Really hoping this gets fixed in next patch. Loading time after darting has at least doubled in length.

1 Like
#4

Agreed, load times (along with fight animations, etc.) all increased noticeably since 1.6

I’ll get a buzz of a dino appearing while commuting to/from work and by the time it loads, I’ll rotate my map 180 to see what it was, and it’s already gone.