Triceratops Gen 2

i think triceratops fans have great X-Mas

Bez názvu

8 Likes

Oh it is first time a common gets its gen 2 right? If it is gonna be legendary, then it is gonna be a huge jump on her stats. That also means a new hybrid is on the way. Well, something to wait for at the ending of a year.

3 Likes

Can we stop with the herbs . Please . For the sake of carnivore dominance

5 Likes

But Triceratops is one of the symbols of the franchise itself. We could make an exception just for her, don’t you think? @Rey :wink:

4 Likes

Anyone else having issues with claiming the reward in the news letter?

This is what I keep getting when trying to claim the reward:
image

2 Likes

Is there a new prize already? I am subscribed to it too. But haven’t received any mentions yet.

They dropped a new news letter this morning for me, that’s where the picture of the trike is coming from.

This link is not working for me:image

2 Likes

It’s not fair tho :weary:

1 Like

i just hope the same that happened with velo and rex g2 happens with trike g2

2 Likes

u mean amphibian dominance

You mean it would be a common or rare gen2 at most?

Hey Sionsith, could you try opening the mail from a different internet browser and see if that works?

yeah.

101010

1 Like

I can’t claim the reward either (using Android, so the message is different, but the result is the same)

Hi, I have tried to open mail from both Chrome and Samsung Internet browsers - and each time I was only redirected to ludia web page

It worked the third try for me

It worked but I had to open the email up in a browser I could not do it from my emails.

Ya. Its first time. U guys just think that, suddenly majungasaurus became a shiny legendary! It will be awsome. All my 4 max majungasaurus will be my strongest dino! Now my strongest dino is a prestosuchus lvl 4, cause i only have 700 thousand food

1 Like

I can’t get it to work either on my android phone. Just sends me here. If I try to copy and paste the url, it just has me download the claim picture.
Screenshot_20201222-093603_Chrome

Nah :frowning: Thanks for the tip, but it didn’t work for me: I tried to open mail in both browsers as well, but again: I have been redirected to ludia.com no matter where I clicked the link from