Ludia Forums

Trouble collecting Twitter rewards

For maybe the last week or two, I’ve been having trouble collecting Twitter rewards.

I get a not found page.

I use an iPad and I’ve tried safari and chrome.


Thanks, Timmah! This has been brought to our team’s attention.

1 Like

Is anyone else having this problem?

I do get some life at ludia page before the not found page, but I only get it once.

Than the not found.

Try using edge browser. This happened to me as well on my iPad when trying to get the daily rewards through chrome or safari. But oddly enough it works perfectly fine on the iPad when I use the edge browser.

1 Like

Edge on an iPad?

I’ve tried chrome, safari and Firefox.

Edit: and it is DB day… why does only edge work?

@Timmah were you able to get it to work with the edge browser?

1 Like

Yes. Thanks.

1 Like

Hello @Timmah,

You might be experiencing this problem because of your iPad settings.

I suggest checking if your Request Desktop Website is on!

Here’s the path to follow on your iPad: *Settings > Safari > Request Desktop Website > All websites >

If All Websites option is on, switch it off.
From there, you should be able to collect the daily rewards as usual when clicking on the daily links!

Hope this helps! :slight_smile:

4 Likes

Hi @Daven i was having this issue as well. I switched the setting you mentioned above and it works now! Thanks a lot!

2 Likes

Fantastic news, @JAD!
Thank you for the follow-up. :slight_smile: