Ludia Forums

Unable to login with google account

Everytime I try it pops up an unknown error and sends me back to main screen asking me to login

I’m sorry that is happening, TehGewg. Do you have a screenshot of the error? Also, please make sure your game is updated to the latest version in the app store.


I uninstalled and reinstalled it so it is the latest but that didn’t fix the error.

Could you please email our support team at so our team can take a closer look?

I’m getting the same error very often.

1 Like

Sorry to hear that, Smazork. If you haven’t contacted our support team yet at, please do so. They’ll be happy to look into this!

Also getting the same error since yesterday afternoon. Sent a ticket. It’s frustrating because I was about to buy gems for the SH event and Vajra. But if I can’t play the game, I don’t see the point of spending money. If I can’t get in today I’m uninstalling for good.

I’m quite sorry for the trouble, Chris_Lontok. Rest assured our team will respond as soon as possible. Thank you so much for your patience.

Sent an email to support 2 days ago and haven’t heard anything back


Hi there TehGewg. I apologize for the wait time. Could you please send me a private message with your support key so I can take a look at your ticket status?

In the meantime, please refrain from sending another email before our team replies as that could reset your position in their queue. Thanks!