Video 20min speed up ads not working

This is for reporting bugs only, if you are having trouble making a purchase or need help recovering your account please post in Help & Support here.

Please fill in the following fields!

Bug Description: Tried doing many things that involve watching ads, zero of them are working for me.

Area is was found in: Anything with an option to use an ad to speed up or save money in the process

How do you reproduce the bug:
Step 1- Try to watch ad to reduce time on dinosaurs in creation lab/use to skip Dinobucks payment on vs battles/rush combining dinosaurs
Step 2 - watch nothing happen after ad.
(add more if needed)

How often does it happen: Every single time I try.

What type of device are you using: iPhone

Anything else? (add screenshots or additional information here)

This is happening to me as well on both my devices. iPhone and iPad

This is happening to me also

Yup…another new bug along with the update.

What model of iPhone and OS are you guys running? I haven’t tried to speed anything up but the ads for the extra spin after a PvP match as well as the ads for the prize drop tickets have been working okay for me.

iPhone Xs
Software version 13.3.1

Currently I am working with the iPhone XR on IOS 13.3.1
Yeah, my wife as well can do the ads for the extra spins, the -20 minutes on certain things, etc, etc as well and I can’t understand why it just happened to me. She’s currently working with an iPhone X on the IOS 13.4 Public Beta 2.

Is everyone on iOS still having issues with the twenty minute speed ups I can watch the videos but it doesn’t change the times

As mentioned before :slight_smile: We are still looking into it.


I can confirm as an iOS user my video speed ups are working just fine. So it’s not just iOS in general but some subset.

@Sionsith thanks I guess it is happening randomly to iOS I saw where a fix should be out sometime next week

@Keith I saw where the fix for iOS will be next week Chris said he was not having a problem with his iOS phone so it must be random

Hi Lora
The fix is for the SDNA being partially hidden by the art and the pack art not loading until you change tabs… that is all update 40.11 addressed
We are working on solution to fix the other issues players have brought up.

This topic would fall under “no credit for videos.”


@Keith thanks that is what I thought about the first patch and if I understand correctly the other issue are being worked on to find a solution

1 Like

I did notice that the ads do work on my Android phone. It’s only my iPad that is effected.

1 Like

Let’s hope that Ludia finds the worm in the apple.

My video speed up started working a couple of hours ago hopefully everyone’s are working now

Still no luck on my end.

Mine are working now.