Ludia Forums

What are the minimum requirements with 1.7x?

#1

What are the minimum requirements to play the game after the new update? The previous version was running fluently but the new 1.7 updates slowed down the same device to the level I can’t play it. The game run actually but it is too slow and the screen is lagging…the game became a “pain” to play.

#2

I’m sorry to hear that your game is feeling laggy, @Buggy. If you have any background apps opened while the game is running, closing them could allow the game to run more smoothly. Also, try restarting your device and see if that helps as well. If you’re still having issues, do not hesitate to contact our support team here at support+forums@ludia.com with your support key and device information.

#3

As the example: AFK Arena (the other game) or PUBG are running smoothly. I guess that something happened with the connections to the JWA servers? I am from Europe… another example: when I want to have a duel than I have timing out reports…like 20 timing outs to 1 game… most of timing outs end ended with the message that the opponent (what opponent???) won and I lose trophies. I drop from 4520 to 3840… what can I do?

#4

It was playable exploration wise on an iPhone 5S I pulled out of the junk drawer and tethered to my then useless Android phone.
Battling I couldn’t tell you