Ludia Forums

What happened to alliance rewards


#21

We had more than a day left.
What happened???
We were close to finishing almost done with both 4s.


#22

I hope they fixed it


#23

Still had over 24 hours left. All of u saying the time was up are wrong


#24

I guess they figured the targets were a bit too hard to get…so they extended with another week…just a guess


#25

Us too. And what’s worse, I can’t even claim the rewards one of my other alliance members got…


#26

Doubt it. We were done


#27

Same thing happened to us! Had like a day a few hour left!! We were like 2k away from unlocking bronze ; ;


#28

Yeah the same thing happend to use too!!


#29

Hmm that’s odd, maybe they are giving us an extra week just to be nice, but the change didn’t work on everyone’s and glitched out? Hopefully everyone didn’t lose their progress!


#30

Unacceptable.


#31

Yet that dosent explain why everybodys prgress restarted to 0! We worked hard to earn what we got!


#32

We were just about 600 required amount of darts to complete to come to the last level. I was darting to check how many remained and than all reset to 0… and not counting anymore.


#33

You are right we worked hard for this?


#34

Well I just got one incubator but not the other one and everything reset to zero now. This blows. I wanted the sino incubator but got the other one. Not happy.


#35

My alliance was close to rank 5. We were only really short on the epic dna required now everything was reset and we didn’t get our sino dna! I am the leader and now the progress won’t even add. Spun 7 stops and got nothing towards the new supply drop mission. It’s like it’s stuck


#36

Hopefully it’s just a temporary glitch and they will fix it! :crossed_fingers:t2::crossed_fingers:t2: Or there will be a lotttt of angry players including myself.


#37

Yeah pur groups progress just rest to 0 too! At least on my end, wth is going on!


#38

Same issue here. All reset to zero and no rewards were delivered…

We’d worked hard to reach rank 4.


#39

All of our progress was wiped out! We were at 4, working on 5. Now zero!

No incubator, no nothing!
When we were supposed to have over a day left to finish!


#40

I received nothing :frowning: