Ludia Forums

What Title Hasn't Been Used

Same so annoying

1 Like

Noice :wink: thanks

1 Like

Whilst I’m here, does anyone know how to fix returning creatures from the sanctuary? She still has them stuck since the last update lol

why no one cover there support keys

Doesn’t seem to be, my members have the same issue I’m the only one on iOS

I switch between lab and map a few times and they appear

Cool, I’ll try that when I can get back on. Cheers :slight_smile:

1 Like

I even tried switching between wifi and cellular data and neither worked

I don’t think it’s just Apple, I have Samsung and I’m getting the same problem, the game is stuck at startup screen.

me too…stuck at 9/27…i havent done my mortem DNA… :weary:

I’ve done pyritator but not m rex

Yeah, I am now getting it on Android too. Sad times

1 Like

It’s on ludias end

I get to 9 before it locks up. Restarting doesn’t help.

1 Like

its working now ! iphone !

1 Like

Hey DPG members, please let me know if you’re able to get past the loading screen now. You might have to relaunch your game.

Thanks!

problem seems fixed back ingame

seems to work now

It works! :slight_smile:

1 Like

I couldn’t log in earlier, but I’m fine now

1 Like