Ludia Forums

Where is support?

This is now the sixth day that a number of players have been unable to play Berk due to a server configuration issue.

So far, support has been completely unresponsive aside from one or two ephemeral promises to “look into it”. While I can’t speak for others, I haven’t received any reply to the ticket I submitted five days ago.

This is unacceptable.

Ludia, someone with official standing needs to put out an announcement days ago detailing what is being done about this, when the affected players can expect a resolution, and what compensation is going to be offered to all the players that have been unable to access the game.

3 Likes

Hey there, I agree with you. I have been waiting for 5 days now. I’ve received an email from support 2 days ago, and yesterday I was told to free up some memory from my device and then retry opening the game. Of course, it didn’t work. There are lots of us having the very same problem, so probably they should consider it’s a more general originated-on-their-side issue. Just a suggestion.

2 Likes

I know it’s on their side. I’ve done the network traffic analysis to prove it. Attempts to log in get bounced with an “untrusted CA” error. That is not caused by insufficient memory or inadequate hardware or any of that BS that support usually blames for their bugs. I suppose it’s possible it’s some sort of botched Man-in-the-Middle attack, but given that a) I can’t imagine what the purpose of such an attack would be, and b) it’s obviously affecting a number of people apparently from all over the world, I consider that unlikely.

I would bet money that something about the TLS¹ authentication chain changed on Friday or Saturday. (I’m less certain it was Ludia’s certificate that changed; it might be an expired CA certificate that’s been reissued, but affected players lack the updated CA certificate.)

(¹ I know I’ve been saying TLS. I think it was TLS, but it might be SSL, which isn’t precisely the same thing. In any case, it’s the network encryption/authentication mechanism.)

2 Likes

Hey robocat3, sorry if we have kept you waiting!
Thanks to the information you and other players have provided, we have received reports that the login issue has been fixed. However, if you are still having difficulties, please contact our support at support+forums@ludia.com so the team can further assist you. Thanks!

It doesn’t seem to have been fixed… is there a hotfix coming out?

1 Like

Right, besides we also missed a Gauntlet Event and Shattermaster’s collection.

I can’t believe they just nuked your workaround.

Fun thing is: looks like the issue is fixed, BUT it requires in-game download which, in turn, requires login, which is impossible without fixing the issue, so it’s a closed loop.
The game didn’t work until I tried installing the certificate manually. However, on my device this is possible only if I set a PIN on the blocking screen, which I really hate, so I was set to deinstall this certificate again.
However, with the new certificate the game launched, did some downloads and was running okay. After that I deleted the newly installed certificate. The game now launches fine, so I guess the downloads included updating certificates in the game itself.

1 Like

Seems that the link is not working anymore. :frowning:

Hi, my kids and i have enjoyed playing this game for years.
Sadly we lost our original account but that’s another story.

We were hit with this log in ‘lightning storms’ msg too.

The game on the ipad seems to have fixed itself but my 4 yr olds android phone version is still unable to connect.
Out of desperation I’ve tried uninstalling the game, even though I’m worried this will have lost his guest account.

Still no joy…

What’s going on???

My game will not start as well. At least I know it is not just me after reading all these other threads. I am also a long-time player, and am really missing the game right now.

I know my wifi is good, as I have two separate networks and have tried both. Other apps on my Kindle work fine over the connections. I have plenty of free drive space.

I start the program and get the “Lightning storms …” message. Then I get the login screen and try to login as “Guest” as I normally do, but I get sent to the previous “Lightning storms…” screen. This repeats itself.

I have powered down and restarted, closed and opened the game too. I hope there will be a fix soon. Thanks.

Hi, all! What’s going on is that the game uses an “untrusted” TLS certificate. The certificate uses two CA signatures, one of which expired on May 30, the other of which was issued more recently than your device has received updates.

Unfortunately, while it is possible to work around the problem, Ludia feels that the work-around is “not safe”.

Robocat, thanks for the explain. I am suffering as I am on a Kindle. I could probably force a cert refresh (locally) on another device, but not what I am using. Ugh.

Heck, I’d renew the cert for them if they would let me! They are relatively cheap compared to what they should be making in game profit. Maybe they are moving from TLS v1. 1 to 1.2. Who knows. I just hope I don’t lose progress when the game comes back. If it comes back.

I know exactly what happened. Their certificate is signed by two (or more, I didn’t actually look closely, but probably two) CA certificates, one of which expired May 30, the other of which isn’t known to your device… with the result that your device (starting May 30) doesn’t trust it and won’t allow a connection. The link I provided in the previous message has more details, and you can also find more information online if you look around. (Presumably RoB isn’t the only service that this affected. The aforementioned article certainly implies as much.)

There isn’t really anything “wrong” with their certificate except what is described in the preceding paragraph. (Multi-signing is harmless except on some broken TLS libraries, which isn’t the case here, and can even be beneficial. In fact, if they had dropped the old CA when switching to the new one, the game would have quit working for the affected players back then.) It’s not even their fault that this happened, really, although it’s certainly unfortunate (if understandable) that this was a surprise, and that there is no official fix yet.

BTW, there are only three resolutions possible:

  • Somehow make the new CA certificate available to players that don’t already have it.
  • Use a totally different certificate from a CA that doesn’t have this problem (although this may just delay the problem until that CA’s certificates also expire).
  • Officially drop support for affected platforms.
1 Like

Mine has been messed up since may, a month now. :angry:

@S.K
Any news on whats going on?
There must be loads of people out there unable to play!

Hey everyone, I’m sorry to hear that you still have not been able to enter the game. Rose had made an announcement here that might help explain the current issue that you are having: [NEWS] Rise of Berk | End of Support for Android 5.0 and Below (June 9th, 2020).

If you had already contacted our support team and is waiting for a reply, our team will be sure to try and get back to you ASAP.

1 Like