Ludia Forums

Will 1.7 still be compatable with my phone

#1

Hi i have a iphone 5c that runs ios 10.3.3 and im worries thaf this update it might no longer support my phone i love this game and i know its unlikely but its always a worry for me and i dont have much to get another device i just dont want to lose this game it gets me out

#2

Considering they mentioned a few devices that were going to have issues… if they didnt mention you… your safe.